How can we help?

macOS 10.15 Catalina - not yet supported in Serato DJ Pro or Serato DJ Lite

macOS 10.15 Catalina is currently in BETA, but is not yet supported for use with Serato DJ Pro, or Serato DJ Lite.

We strongly recommend you do not update until we announce support

We have been performing tests with BETA releases of macOS 10.15 Catalina, and have noticed significant issues, which we are currently working through.

We hope to announce support for macOS 10.15 Catalina in both Serato DJ Pro & Serato DJ Lite after the public release of macOS 10.15 Catalina.

It may be worth disabling automatic updates, to avoid potentially clicking the "Install update" button in the macOS pop-up notification, via System Preferences --> App Store --> Automatically check for updates (uncheck)