Pitch 'n Time Pro 2.4+ required to use the Pro Tools 7.4 TC/E tool

Product:
Pitch 'n Time Pro 2.3.1 or earlier, with Pro Tools 7.4 or later.

Issue:
The TC/E tool does not work as expected.

Solution
Download and install the latest version of Pitch 'n Time Pro.

This is a FREE update for owners of Pitch 'n Time 2.2 and Pitch 'n Time Pro 2.3. Your current iLok license will work with Pitch 'n Time Pro 2.4.