Serato Support

How can we help?
or Open help request

macOS 10.14 Mojave not yet supported in Serato DJ Pro or Serato DJ Lite

We currently do not recommend updating to macOS 10.14 Mojave, for use with Serato DJ Pro or Serato DJ Lite.

We have been running tests with the BETA releases up until this point and things are looking positive, but we cannot complete our final testing until the public release of macOS 10.14 Mojave becomes available.

We hope to announce support as soon as possible, after the public release.