Serato Support

How can we help?
or Open help request

What are the system requirements for Serato Remote?

Please ensure your iPad meets the minimum system requirements for use with Serato Remote:

  • iPad 2 or above or iPad mini
  • iOS 6 or above
  • It is necessary to have the latest version of iTunes installed

Please ensure that your laptop also meets the minimum system requirements for use with Serato DJ or Scratch Live.